FC2ブログ

徒然さめざめ

思ったことを思ったときに思ったように

Redmine 1.2.1.devel から HEAD(Redmine 3.0.1.devel.14180)までのバージョンアップ

確認した環境は CentOS5.11、rvm使用

ruby 2.1 へバージョンアップ(インストール)
省略

bundlerが無ければインストール

gem install bundler --no-rdoc --no-ri


ImageMagick 6.9.1-1 のインストール
必要かどうかわかんないけどDL

yum install fftw3 openexr openexr-devel ghostscript-devel jasper-devel lcms2-devel libwebp-devel


wget http://www.imagemagick.org/download/ImageMagick.tar.gz
tar xvzf ImageMagick.tar.gz
cd ImageMagick-6.9.1-1
./configure --prefix=/usr
make
make install


redmine アップデート

svn update
config/database.yml のアダプターを mysql から mysql2 に変更
bundle install

bundle exec rake generate_secret_token
RAILS_ENV=production bundle exec rake db:migrat


プラグインとか入れてなければこれで一応おわりのはず。

* ImageMagickのアップデート
* mysql から mysql2 に変更
* 初めてruby2系を使う
* 同 bundle を使う
スポンサーサイト